原文:Debian/Ubuntu系统开启TCP-BBR拥塞控制一键安装脚本

注意:TCP-BBR和锐速一样,不支持Openvz,查看本教程之前,请先确定你的VPS的虚拟化技术!

注意:本教程涉及到VPS更换内核,所以如果步骤错误,或者VPS不兼容最新的内核,会导致无法开机等错误,请勿用于生产环境!

系统要求

Debian / Ubuntu 14.04 +

本脚本只在 Debian 7 / Debian 8 / Ubuntu 14.04 / Ubuntu 16.04 (均 x64位) 这几个系统中测试过脚本可以正常运行(Vultr)!

强烈推荐 Debian 7 x64,这个是我一直使用的系统,我的脚本在这个系统上面出错率最低。并且最容易安装锐速(锐速不支持OpenVZ)

至于为什么不支持 CentOS 等系统,主要是我不怎么用其他的系统,就不做支持了。

脚本版本

Ver: 1.0.2

内核版本: 4.9.0 正式版 (建议升级,降低了断流的几率,虽然我测试一天了也还没遇到,不知道修复了没有。)

安装步骤

wget -N --no-check-certificate https://soft.dou-bi.co/Bash/bbr.sh && chmod +x bbr.sh && bash bbr.sh

下载并运行脚本后,会自动检测并开始安装。

如果没有出错,安装完毕后,会自动重启VPS,不需要担心。

等待十几秒,VPS启动后,重新通过SSH连接VPS,然后执行下面这个命令。

使用方法
# 启动BBR

bash bbr.sh start

# 停止BBR

bash bbr.sh stop

# 查看BBR状态

bash bbr.sh status

# 升级BBR

bash bbr.sh

注意:停止BBR,需要重启VPS,所以脚本会提醒是否立即重启VPS。

因为BBR是集成在内核中的,所以不能卸载,除非更换其他的内核。

其他说明

注意:TCP-BBR和锐速一样,不支持Openvz,查看本教程之前,请先确定你的VPS的虚拟化技术!

注意:TCP-BBR必须是更新的 4.9.0-rc8 内核及以后的版本才能开启,而锐速并不支持这个最新的内核版本,所以TCP-BBR和锐速是不可能共存的。

提示wget: unknown host “soft.dou-bi.co” 之类的错误

这是无法解析我的域名,多半是DNS的问题,请更换DNS为谷歌DNS。

echo "nameserver 8.8.8.8" > /etc/resolv.conf
echo "nameserver 8.8.4.4" >> /etc/resolv.conf